Valley Road Maraekakaho
Incident Report for AoNet Broadband
Resolved
Faulty components were replaced and the site is now online.
Posted 8 months ago. Feb 25, 2019 - 13:48 NZDT
Investigating
Site has currently gone offline, we are investigating and dispatching a tech ASAP
Posted 8 months ago. Feb 25, 2019 - 09:53 NZDT
This incident affected: Internet Services - Hawkes Bay (Maraekakaho).