Outage affecting some Ruapehu customers
Incident Report for AoNet Broadband
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 11, 2019 - 08:18 NZST
Identified
A technician is heading to the site to restore service ETA 4pm
Posted about 2 months ago. Apr 10, 2019 - 12:36 NZST
This incident affected: Internet Services - Taumarunui.