Hikurangi outage
Incident Report for AoNet Broadband
Resolved
This incident has been resolved.
Posted Jul 07, 2020 - 13:25 NZST
Investigating
Site is off air, were currently investigating this issue.
Posted Jul 07, 2020 - 09:26 NZST
This incident affected: Internet Services - Taumarunui.