Rangitapu Signal Level
Incident Report for AoNet Broadband
Resolved
This incident has been resolved.
Posted May 01, 2020 - 10:32 NZST
Investigating
The link into our Rangitapu Site has low signal, we expect this is because of wind issues earlier this morning.

Techs are on the way to the site.
Posted Jan 31, 2020 - 13:59 NZDT